This incident was resolved by the upstream carrier at about 4:05 PM CDT. If you are still experiencing any issues with inbound calls, please reach out to our support at 972-293-1550 ext 2.
Posted Sep 10, 2026 - 18:56 CDT
Investigating
A national upstream carrier has reported an issue which is causing one-way/degraded audio on inbound and outbound calls. We re-routing calls as possible and will update this notice as it resolves.
Posted Sep 10, 2026 - 12:02 CDT
This incident affected: Audio Path and US Inbound Calls.